Issue:
I've clicked on a content item that is a hosted PDF article. When the article page opens, I see a toast message on the bottom of the screen saying 'There was a problem loading the page.'.
Why am I unable to open the article?
Cause:
The PDF file originally uploaded to Degreed was corrupted or empty.
Resolution:
Contact the content owner and request them to open the original file and ensure there is data in it and it's not corrupted or empty.
Once the file is verified to be working, the content owner will need to edit the article in Degreed and re-upload the file. To do so, follow the instructions in the article Edit a Content Item from the Manage Catalog Page.
Additional Note:
If you wish to confirm the issue is with the file, open your Dev Tools Console tab and refresh the page. The error 'InvalidPDFException: The PDF file is empty, i.e. its size is zero bytes.' will be shown in the Console tab.