Issue:
After adding a video URL to Degreed, I see the thumbnail showing the error message 'Sorry this video does not exist.', or 'We’re having a little trouble'. Why is that?
Cause:
The video URL contains additional parameters that are causing the error message. When adding any video URLs to Degreed, ensure to include only the content's base URL, without any add-ons such as "?share=copy".
Resolution:
On the manage organization's Catalog page, edit the video URL of the content so that it contains only the base URL of the link and save. This will update the item and remove the thumbnail error message, should the new link be correct.
If you do not have access to edit the internal catalog, contact your organization's administrator, who will be able to assist you with this update.