Issue:
When I take the onboarding tour, I see its content in the language of my browser, although my Preferred Content Language and Degreed Display Language are set to a different one. This also happens when I use search features, such as adding new skills to my profile - the skills show in a different language. Why is that?
Cause:
The fact that the text displays the browser's language and not Degreed's display language is expected behavior if the browser is set to translate text to your browser's preferred language. Therefore, if your browser's preferred language differs from Degreed's display language, the former will prevail.
For Google Chrome, we recommend you to refer to Google's Change Chrome languages and translate webpages article, where behavior regarding language is described.
Resolution:
You can always change your browser's preferred language if you wish to change this behavior.