Problème :
J’ai créé une nouvelle automatisation qui sera déclenchée lorsqu’un événement donné, comme la complétion d’un parcours, se produit. Cette nouvelle automatisation fonctionnera-t-elle pour les utilisateurs qui ont déjà effectué l’événement, tels que ceux qui ont déjà terminé le parcours ?
Cause :
Les automatisations ne sont pas exécutées rétroactivement. Elles ne sont déclenchées que pour les actions survenues après leur création.
Résolution :
Si vous souhaitez qu’une automatisation s’applique à tous les utilisateurs ayant déjà effectué une action, vous devrez forcer l'action à se dérouler à nouveau.
Remarque supplémentaire :
Par exemple, pour réactiver une automatisation qui s’applique aux utilisateurs ayant terminé un parcours, vous devrez éventuellement charger un modèle Mise à jour d’utilisateurs en supprimant l’un des éléments terminés de l’utilisateur dans le parcours, puis charger un autre fichier Mise à jour d’utilisateurs ajoutant à nouveau cet élément terminé. Cela entraînera à nouveau la complétion du parcours, activant l’automatisation qui sera ensuite exécutée pour cet utilisateur.