Summary:
At 12:30 PM CET (11:30 PM UTC) on Jan 28th, 2025, users in our US data center may have experienced latency issues resulting in a timeout when attempting to access the Degreed platform.
This issue impacted US customers that have Academies enabled.
Root Cause:
The ACM identity service became unresponsive, due to excessive load on the database, which prevented the LXP from obtaining an access token needed to make requests to the ACM API. The LXP relies on the ACM API to retrieve authenticated user data. As a result, the LXP application experienced timeouts when trying to request user information.
Plans for Improvement & Prevention:
We will work to modify the LXP HTTP client that handles errors while making the request to protect against the ACM API from going down.