Summary:
At 5:51 AM PT (1:51 PM UTC) on Jan 17th, 2025, customers in our EU data center may have experienced latency issues resulting in a timeout when attempting to access the Degreed platform. During this time, the Degreed platform was unaccessible. The system was fully restored and operational again at 6:16 AM PT (2:16 PM UTC) Jan 17th, 2025.
Root Cause:
A minor network update became stuck during processing, leading to misalignment of some network resources.
Plans for Improvement & Prevention:
Our engineering team paused the update, removed the incomplete elements, and successfully restarted the process.