Zusammenfassung
Am 27. August 2025 hatten einige Kunden bei der Anmeldung bei Degreed Probleme mit der Einmalanmeldung (Single Sign-On, SSO).
Ursache
Eine Änderung der Netzwerkkonfiguration, die während der Fehlerbehebung für das Herunterladen von Videos/Artikeln vorgenommen wurde, hat die SSO-Authentifizierung auf der gesamten Plattform versehentlich gestört. Obwohl die Änderung sofort nach der Erkennung zurückgesetzt wurde, hat sich die Wiederherstellung des Dienstes aufgrund der Weitergabe an die Edge-Knoten verzögert.
Lösung
Die Änderung am Netzwerk wurde rückgängig gemacht und sobald die Weitergabe über alle Edge-Knoten abgeschlossen war, wurde die SSO-Funktionalität vollständig wiederhergestellt. Das normale Anmeldeverhalten wurde mittlerweile verifiziert.
Präventive Maßnahmen
Um ein erneutes Auftreten von Problemen zu verhindern, wird das DevOps-Team alle Änderungen am Produktionsnetzwerk im Voraus ankündigen und sie während der geplanten Wartungsfenster planen.