Issue:
I already created my account, however, I can't access it. And I'm not receiving the password reset email when I click on Set/Reset password.
Cause:
There are two reasons for the error message 'The email or password provided is incorrect' to be raised when trying to access your account:
- Incorrect credentials — email or password are not the same used for the creation of the account
- Incorrect URL — you're trying to access using the wrong URL
Degreed accounts are tied to a single Data Center, and each of them uses a different base URL.
Resolution:
Make sure you're accessing the correct URL:
Data Center | Base URL |
United States of America (US) Based Companies | https://degreed.com/ |
Europe (EU) Based Companies | https://eu.degreed.com/ |
Canada (CA) Based Companies | https://ca.degreed.com/ |
If you're still having issues accessing your account, create a ticket with Degreed Technical Support via this form: Submit a Ticket. Make sure to add your full name and organizational email.