Issue Description:
I want to edit a chat message I sent in Microsoft Teams, but I do not see the Edit option. Why can’t I edit my message?
Cause:
You cannot edit a message if one of the following conditions applies:
The message was not sent by you
Your organization has disabled chat message editing
The message is outside the allowed editing time frame
The message type (for example, certain system messages) does not support editing
Resolution:
To edit a message (if editing is enabled):
Hover over the message
Select the More options (⋯) menu
Click Edit
Update the message
Select the checkmark to save your changes
After you save the update, Microsoft Teams displays Edited below the message.
If you do not see the Edit option:
Confirm that you sent the original message
Verify whether your organization allows message editing
Contact your internal IT team or administrator to confirm messaging policy settings
Additional Note:
Message editing availability depends on your organization’s configuration and messaging policies within Microsoft Teams.