Issue:
Skill Coach was activated not too long ago, but I can see manager skill ratings from the last few years in the reports.
Cause:
This is expected behavior.
Resolution:
The ability to provide a manager skill rating is available without Skill Coach and was implemented before Skill Coach was introduced.
The difference is that without Skill Coach, the user has to request the manager rating, whereas with Skill Coach, the manager can complete a rating without needing a request from the user.
Additional Note:
Check also the article Skill Rating Types.