Summary
Wir haben kürzlich ein Problem mit erforderlichen Lerninhalten identifiziert: Erledigte Inhalte können auf der Startseite des oder der Lernenden weiterhin als „Zugewiesen“ oder „Erforderlich“ erscheinen, auch nachdem der Benutzer oder die Benutzerin den Inhalt abgeschlossen hat. Das Problem besteht weiterhin, obwohl in allen RL-CSV-Dateien Fälligkeitsdaten enthalten sind.
Schritte unternommen:
Wir haben die meisten der zugrunde liegenden Probleme mit den Daten Sammlern identifiziert und gelöst. Durch die jüngsten Optimierungsbemühungen sind jedoch einige neue Probleme aufgetreten, an deren Lösung wir aktiv arbeiten.
Workaround:
Als Alternative zur Degreed-Startseite kann der Benutzer oder die Benutzerin seine Degreed-Sammlungsseite besuchen, um den Abschluss zu überprüfen.
Nächste Schritte:
Die Lösung des Problems dauert länger als erwartet. Am 13./11 haben wir jedoch einige Leistungsverbesserungen vorgenommen, die positive Zeichen zeigen. Wir überprüfen weiterhin die offenen Probleme und werden diese Seite auf dem Laufenden halten.
Ursache
Das Problem scheint mit vorübergehenden SQL-Fehlern während der Sammlerprozesse in Verbindung zu stehen, was speziell Zeilen in der Datenbank betrifft, die nicht in den Status „Erledigt“ übergehen. Weitere Details werden folgen.
Pläne zur Verbesserung und Prävention
Weitere Backend-Optimierungen sind im Gange, um die Datensatzverarbeitung zu verbessern und Wiederholungen zu verhindern. So wird sichergestellt, dass die abgeschlossenen Kurse korrekt angezeigt werden. Die Entwicklungs- und Integrationsteams priorisieren Tests und Bereitstellungen, um eine Lösung des Problems zu beschleunigen. Weitere Details werden folgen.