Problem:
Ich vergleiche die Fertigstellungsdaten von der API mit der In-App-Berichterstattung und stelle Unterschiede in den Daten fest. Einige Erledigungen fehlen beim Filtern nach Inhaltsanbieter, Inhaltstyp oder Verifizierungsstatus. Außerdem stimmen die Anzahl und Datum der Erledigungen in den API- und In-App-Berichten nicht überein.
Ursache:
Dieser Unterschied tritt auf, weil die API- und In-App-Berichte Fertigstellungsdaten unterschiedlich verarbeiten:
- Das Feld API completed_at wird nur ausgefüllt, wenn eine Fertigstellung durch eine Integration, eine API oder einen Dateiupload verifiziertwird
- Wenn ein Benutzer oder eine Benutzerin ein Element manuell als erledigt markiert, gibt die API einen Wert null für completed_atzurück.
- Der In-App-Bericht zeigt stattdessen das Datum hinzugefügt_at als „Datum der Fertigstellung“ an, wenn keine verifizierte Fertigstellung existiert
Infolgedessen kann es vorkommen, dass dieselbe Erledigung im In-App-Bericht ein Datum enthält, in der API jedoch ein Null- oder fehlendes Fertigstellungsdatum, was zu nicht übereinstimmenden Datensätzen oder Zählungen führt.
Lösung:
So gleichen Sie die Unterschiede zwischen API- und In-App-Berichten ab:
- Vergleichen Sie bei der Analyse von API-Daten die Felder completed_at und added_at
- Erledigen Sie completed_at = null für Erledigungen, die manuell als erledigt markiert und nicht durch Integration oder Dateiupload in den API-Daten verifiziert wurden
- Vermeiden Sie es, sich bei der Validierung von Summen oder dem Filtern von Ergebnissen ausschließlich auf completed_at zu verlassen